by eggsurplus

Control what your users can access and save time, money, and frustrations. Lock down sensitive data in SugarCRM or SuiteCRM to specific groups or teams. Supports unlimited assigned users, unlimited group assignments to records, custom layouts for each group, login/sudo capabilities and much more.

Free 30 day trial
Try it Now

By clicking you consent to share your profile with the developer

#2851 - Layout for Group = Error Occurred

Closed Bug? created by taufiqueahmed Verified Purchase 5 years ago

Hi Guys Having an issue with 7.7.9 SuiteCRM

I have 2 groups that want different layouts Main group has default 2nd group has custom

This worked for about a week

Now if you make an update to either layout it makes it the default layout?

Happy to connect and show As always thank you for the help Regards

  1. eggsurplus member avatar

    eggsurplus Provider Affiliate

    5 years ago

    Has anything changed since then such as turning on some sort of caching module on the server?

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      5 years ago

      Just following up on this. Any changes on your server or configuration from when it worked to when it stopped? For example, adding a caching mechanism on the server?

  2. taufiqueahmed member avatar

    taufiqueahmed Verified Purchase

    5 years ago

    Sorry missed the first reply! Thank you No changes on this server that I or administrators are aware of

  3. taufiqueahmed member avatar

    taufiqueahmed Verified Purchase

    5 years ago

    Any chance we can share screens or system information again?

    As always thank you for the support

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      5 years ago

      Can you email me at solutions@eggsurplus.com with credentials to your install along with steps to reproduce the issue? I may need temporary server access as well as it may be related to the file system. Thanks!

  4. taufiqueahmed member avatar

    taufiqueahmed Verified Purchase

    5 years ago

    Hi Again :) Thank you so much for the bug patch you sent me

    It has resolved 99% of our issues The errors are removed and layouts are correct!

    One side issue that is continued that affects the group SuiteCRM Reporter If I create a report for 1 module for example meetings and only use meeting fields the report will work for users in the group

    It will only show them the meetings they are allowed to see etc and works great

    As soon as I add any fields from another module ie Organisation, the report is blank for the user in the group

    I have tried this the other way around, Organisation is primary and all works, add any meetings fields and results are blank

    Hope this makes sense Thanks

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      5 years ago

      I see the issue. Looks like a problem in SuiteCRM itself. I might be able to find a quick fix to submit to SuiteCRM. Will keep you posted.

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      5 years ago

      A pull request with the fix has been made here: https://github.com/salesagility/SuiteCRM/pull/3155

      The change is on line 1211 and requires changing the last param of the function call on this line:

      $query['join'][$alias] .= $this->build_report_access_query($rel_module, "`$alias`");
      
  5. eggsurplus member avatar

    eggsurplus Provider Affiliate

    5 years ago

    It looks like SuiteCRM merged the fix into their code base. Going to close this out for now.

This case is public. Please leave out any sensitive information such as URLs, passwords, etc.
Saving Comment Saving Comment...
Rating
Rating