by eggsurplus

Control what your users can access and save time, money, and frustrations. Lock down sensitive data in SugarCRM or SuiteCRM to specific groups or teams. Supports unlimited assigned users, unlimited group assignments to records, custom layouts for each group, login/sudo capabilities and much more.

Free 30 day trial
Try it Now

#519 - Module loader

Closed Bug? created by Stefan Verified Purchase 5 years ago

I had a SugarCRM CE v6.5.13 installation with SecurityGroups - Premium Edition v2.6.5 and I upgraded to v6.5.16 and v2.7.2 respectively. In the module loader screen, it still lists the SecurityGroups - Premium Edition v2.6.5 as installed and the SecurityGroups - Full Edition v2.7.2 as uploaded but not installed (even though the installation went through fine). I simply install over the previous version as mentioned in your documentation.

  1. eggsurplus member avatar

    eggsurplus Provider Affiliate

    5 years ago

    There is something that can happen on certain servers with SugarCRM's Module Installer that cause a module not to show as installed in Module Loader. This seems to be very rare. Just to ensure that it did fully install, run that 2.7.2 through the install process again.

    Then check config.php in your root SugarCRM directory and look for 'securitysuite_version'. That should be 6.5.16. If not, then the install isn't completing and usually it is due to not having write permissions on config.php.

    After you see 6.5.16 in config.php then remove the 2.7.2 zip and manifest from /upload/upgrades/module. That should remove it from the not installed list. The installed listed will still show as 2.6.5.

  2. staganyi member avatar

    Stefan Verified Purchase

    5 years ago

    That is what I find weird because the folder has the correct permissions but I think it is not updating config.php for some reason because I had to manually change the config param $sugar_config['securitysuite_version'] = '6.5.16'; after upgrading because I would get the version number didn't match error (https://www.sugaroutfitters.com/support/securitysuite/334). The module loader completes to 100% so I'm guessing it installed correctly?

  3. eggsurplus member avatar

    eggsurplus Provider Affiliate

    5 years ago

    Yes, it installed correctly. If you manually set that value then you'll be good to go. I need to remove the usage of config.php going forward.

  4. staganyi member avatar

    Stefan Verified Purchase

    5 years ago

    Is it safe to "Delete Package" from the uploaded section of the module loader or should I leave it there?

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      5 years ago

      That's actually a better idea than my suggestion. Deleting a package will remove it from that upload directory and it won't uninstall what is already installed. So yes, that is safe in this case. (Always back up everything just in case)

This case is public. Please leave out any sensitive information such as URLs, passwords, etc.
Saving Comment Saving Comment...
Rating
Rating
  • "No brainer. I have purchased it for two production installations and not regretted it."

    Read More Reviews

Keep up to date on the latest additions

We'll send you an email every month with handpicked add-ons, reviews, tricks and tips. Don't worry, we hate spam as much as you do.