by eggsurplus

Control what your users can access and save time, money, and frustrations. Lock down sensitive data in SugarCRM or SuiteCRM to specific groups or teams. Supports unlimited assigned users, unlimited group assignments to records, custom layouts for each group, login/sudo capabilities and much more.

Cancel at any time!
Free Trial

#269 - Error on assigning custom module to security groups

Closed Bug? created by vytenis Verified Purchase 5 years ago

I have just installed security suite. Then do some hookups for my custom modules, I create new group, assigned users and roles for it. It orks. But when i try to assign my custom module I receive error:
Fatal error: Call to a member function addBean() on a non-object in /var/www/ctms/data/Relationships/M2MRelationship.php on line 136 Call Stack: 0.0000 652864 1. {main}() /var/www/ctms/index.php:0 0.0999 14173880 2. SugarApplication->execute() /var/www/ctms/index.php:48 0.1673 17989024 3. SugarController->execute() /var/www/ctms/include/MVC/SugarApplication.php:89 0.1673 17989024 4. SugarController->process() /var/www/ctms/include/MVC/Controller/SugarController.php:289 0.1737 18624920 5. SugarController->handleActionMaps() /var/www/ctms/include/MVC/Controller/SugarController.php:375 0.1750 18720856 6. require_once('/var/www/ctms/include/generic/Save2.php') /var/www/ctms/include/MVC/Controller/SugarController.php:901 0.1823 19231056 7. Link2->add() /var/www/ctms/include/generic/Save2.php:197 0.2145 20690840 8. M2MRelationship->add() /var/www/ctms/data/Link2.php:492

This I have done:
Run Admin->Repair->Repair Roles
Run Admin->Repair->Rebuild Relationships

  1. eggsurplus member avatar

    eggsurplus Provider Affiliate

    5 years ago

    Can you email me your custom/metadata/XXXXXX.php file that defines the relationship to solutions [at] eggsurplus [dot] com? How are you trying to assign the group to the custom module? By adding the group via the Security Groups subpanel under that custom module? What version of SugarCRM are you running this on?

  2. eggsurplus member avatar

    eggsurplus Provider Affiliate

    5 years ago

    We worked through the issue outside of this case and found that the subpanel was hidden under Admin->Display Modules. Dragging that over to Display and saving resolved the issue.

This case is public. Please leave out any sensitive information such as URLs, passwords, etc.
Saving Comment Saving Comment...
Rating
Rating
  • "Couldn't do without it. Highly recommended and I guarantee that you will not find another alternative."

    Read More Reviews

Keep up to date on the latest additions

We'll send you an email every month with handpicked add-ons, reviews, tricks and tips. Don't worry, we hate spam as much as you do.