by Fanatical Labs

Enable your support and sales teams by giving them the visibility they need. With this Zendesk and SugarCRM integration your teams will be able to stay up-to-date on all relevant records whether you are in Zendesk or in Sugar.

Cancel at any time!
Free Trial

#2969 - Module 2.0.0 installed - Intelligence panel throwing 500 error

Closed Bug? created by mhoffmann Verified Purchase 2 years ago

Hi,

After updating the 2.0.0 module (several attempts on a test system where initially it stopped on 80%) everything appeared OK.

One issue, when we try to load the FZ dashlet in an info panel, we are getting a 500 internal server error. All file rights appear to be OK

Any ideas?

Regards
Malcolm

  1. chad member avatar

    Hi Malcolm, thanks for giving it a try, but sorry for the issue.

    If the script isn't reaching the 100% completion point then the post_install script is not being run. There is some stuff in there that is required to make it all work.

    What version/edition of Sugar are you using? Can you check your sugar logs AND php error logs to see if anything is showing up there?

    Thanks!

    • mhoffmann member avatar

      mhoffmann Verified Purchase

      2 years ago

      Hi Chad,

      The installation did complete after several different ways of testing, system is a 7.7.2.1 Ent.
      We found we could only install the module without deinstalling the previous version.

      After updating the production system in the same manner, we then found the dashlets in the intelligence pane were throwing the 500 error

      Regards Malcolm

    • chad member avatar

      Got it, thanks for the information. A few questions and things to try:

      1) Is the dashlet failing when you are viewing a Lead? (it looks like the dashlet is not enabled in our code to work for the Leads module, this is something I can correct) Does it work if you use the dashlet on a Contact?

      2) Go to Sugar > Admin > Zendesk Configuration, go to step 3 "Connect", make sure the Zendesk Subdomain is there click the "Connect to Zendesk" button

      Even though it may say "already connected", click the "Connect to Zendesk" button again. After doing that go back to the dashlet and see if it works.

      3) If that does not work, run a Quick Repair and Rebuild, go back to the dashlet and see what happens.

      Let me know what you find. Thanks for your patience!

    • mhoffmann member avatar

      mhoffmann Verified Purchase

      2 years ago

      Hi,

      1) I don't see the dashlet for leads! I tried with accounts and contacts but it fails in both modules.

      2) I can't check the connection to Zendesk as I don't have the user credentials. I will ask the customer

      3) Already tried doing a Quick Repair with no effect

      Next step, get customer to validate step 3.

      Thanks for your help so far

      Regards
      Malcolm

  2. chad member avatar

    Hi again Malolm, I think I found the cause for the issues you're seeing.

    Can you please download the latest package from your orders page and install it in the module loader? (you do not need to uninstall the one that is there) I expect this new package to reach 100% installed.

    After it installs, be sure to go to Sugar > Admin > Zendesk Configuration, go to step 3 "Connect", make sure the Zendesk Subdomain is there click the "Connect to Zendesk" button. Even though it may say "already connected", click the "Connect to Zendesk" button again. After doing that go back to the dashlet and see if it works.

    Let me know if that clears things up. Thanks!

    • mhoffmann member avatar

      mhoffmann Verified Purchase

      2 years ago

      Hi Chad,

      I installed the new package, installed without issues. Also the dashlets are now working in the information panes for accounts and contacts, nothing visible for leads.

      Cheers
      Malcolm

    • chad member avatar

      Good to hear! Thanks for giving that a try.

      When you say nothing is visible, do you mean you cannot select the "Fanatical Zendesk" dashlet to add when viewing a Lead record? Or after adding the dashlet, there are no tickets?

      If you can add the dashlet, but there are no tickets, go to Zendesk and verify if there is anyone in Zendesk with a matching email address. If there is not, then you will first need to add that person to Zendesk with the email address.

      If a person does exist in Zendesk with the Lead's email address, but they have no tickets, there will be no tickets shown in the dashlet in Sugar.

      Let me know if that helps. Thanks again!

    • mhoffmann member avatar

      mhoffmann Verified Purchase

      2 years ago

      Hi Chad,

      I don't see a FZ dashlet in leads which I could add

      Regards Malcolm

    • chad member avatar

      I'm seeing it now on our end, so my guess is it is a cache issue. A few more things to check:

      1) Did you download and install the package for Sugar 7?

      2) Are you looking at a specific Lead or the list view of Leads? It can only be added to the 'record' view.

      3) Try doing a Quick Repair and Rebuild, then go to a specific Lead, perform a hard refresh (windows: ctrl+shift+R or mac: cmd+shift+R), then try to add the dashlet again. See if "Fanatical Zendesk" dashlet shows in your list.

      Thanks!

  3. mhoffmann member avatar

    mhoffmann Verified Purchase

    2 years ago

    Hi Chad,

    We got an error reported from our customer today. The account detail view was throwing a 500 error. One of our developer's deinstalled the Zen connector module (he said the old and the new version were installed) and now the customer system is working again w/o the Zendesk integration.

    What do we need to do to activate the connector again and to avoid the system throwing errors?

    Regards
    Malcolm

    • chad member avatar

      Hi Malcolm, there is a new package 2.0.1 that corrects this issue. Sorry for the troubles.

      If they download the new package (https://www.sugaroutfitters.com/orders) go to Sugar > Admin > Module Loader and install it over what is currently there (do not uninstall anything).

      Same process as before, after it installs go to Sugar > Admin > Zendesk Configuration (it should redirect you here) and go through the setup steps. Be sure to click the "connect to Zendesk" button on step 3 even if it says you are already connected.

      There was a missing file in the old package, which is what was causing the 500 errors. Should be good to go with the new package. Let me know if that doesn't work.

      Sorry again!

  4. mhoffmann member avatar

    mhoffmann Verified Purchase

    2 years ago

    Hi Chad,

    This version appears to be working now, after we did a resinstall of the module.

    Please close the case

    Malcolm

This case is public. Please leave out any sensitive information such as URLs, passwords, etc.
Saving Comment Saving Comment...
Rating
Rating
  • "They did a great job customizing our Sugar/Zendesk plugin. I love that you don't have to explain everything, they just get it."

    Read More Reviews

Keep up to date on the latest additions

We'll send you an email every month with handpicked add-ons, reviews, tricks and tips. Don't worry, we hate spam as much as you do.