by eggsurplus

Control what your users can access and save time, money, and frustrations. Lock down sensitive data in SugarCRM or SuiteCRM to specific groups or teams. Supports unlimited assigned users, unlimited group assignments to records, custom layouts for each group, login/sudo capabilities and much more.

Free 30 day trial
Try it Now

#762 - License Key not working

Closed Installation created by Knowlarity Communications India Limited 5 years ago

Hi,

I purchase Security suite. But my license key is not getting validated. The error message I get is the following

" Please renew your subscription or check your license configuration"

We tried to even to generate link but that dint work.

  1. eggsurplus member avatar

    eggsurplus Provider Affiliate

    5 years ago

    Hello,

    It looks like your key is validating just fine here. Sometimes this message will stick around for a page or two after validating your key due to how SugarCRM works. If you go ahead and go to another module or to the home page this error will disappear. If not, perhaps it is some sort of opcode cache that is displaying this old message.

    -Jason

  2. eggsurplus member avatar

    eggsurplus Provider Affiliate

    5 years ago

    Just to clarify, I see that your attempts to validate the key has hit the license server and is validating just fine. Hopefully that message has gone away for you now.

    -Jason

  3. vaibhavjha member avatar

    Hi,

    We have 2 security suite licences and working in 2 separate instances. In one instance we can't find mass assign in listView of Leads, Contacts, Accounts etc. modules. Also, when we are trying to access security suite setting screen, it lands up on blank page. While in other instance both these things are working fine. Can you please assist us, where we might have went wrong?

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      5 years ago

      Whenever it works in one instance and not the other it will always be due to file permissions, even if you swear it can't be possible. It can be a real head scratcher. Now the question is when the file permission issue come into play? Meaning did it copy over the files correctly or not during install?

      I'd start with these 2 docs:

      http://support.sugarcrm.com/04_Find_Answers/02KB/02Administration/100Install/Required_File_System_Permissions_on_Linux/
      http://support.sugarcrm.com/04_Find_Answers/02KB/02Administration/100Install/Setting_File_Permissions_and_Ownership_in_config.php/

      Set up the permissions/ownership and see if that fixes it. If not, see if config.php and config_override.php is readable. Also see if /modules/SecurityGroups/config.php and config.html is there (along with AssignGroups.php).

      I did check both licenses and they are validating fine.

  4. vaibhavjha member avatar

    Thanks for your reply. I have checked config.php and config_override.php as given in documents. Default permissions in config.php were already there, but in config_override.php Default permission user and group are not there. I can see all security suite related settings in config_override.php file. I also can see all three files you mentioned in modules/SecurityGroups/ folder. Is there any way to track the issue?

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      5 years ago

      Check and compare the file permissions and ownership between the site that doesn't work and the one that does. This might come in handy for properly setting up/fixing permissions:

      http://www.shanedowling.com/sugarcrm-permissions-script/

  5. vaibhavjha member avatar

    Hi,

    There is no mass assign in listview and subpanel of security suite in custom modules. How can I get these?

    Thanks,

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      4 years ago

      To add support for any custom modules just go to the Admin page and then in the SecuritySuite section click on the Hookup Tool. Run the tool for that custom module. It will now have Security Groups support including the mass assign panel on the list view and the subpanel on the detail view.

  6. vaibhavjha member avatar

    Thanks for the support. Now I am able to get custom modules in security group.

    One more issue we just faced, after upgrading security suite to professional. It saved some language files in custom/Extension/modules/ModulBuilder/Ext/Language with Unicode BOM and Builder's module deploy,publish e.t.c functionality stops. It took me almost a day to find and sort this out. Can you please resolve this issue?

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      4 years ago

      Just to confirm, you are up and working right now, right? We'll look at the file encoding for future upgrades.

  7. vaibhavjha member avatar

    yes, we are working now. Just wanted to bring into your notice to resolve in future upgrade.

    One more thing, when I am trying to validate my product instance's key on staging server it throughs error "Error: Free Trial has expired and payment failed. Update payment information on SugarOutfitters to continue usage." Can you please look into the issue. FYI: IP of my staging is http://10.60.20.125/dev_SuiteCRM.

    Let me know, if you need some more information regarding this.

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      4 years ago

      It looks like one of your licenses expired and couldn't renew. I'll email you with more information on how to get that up and running again.

This case is public. Please leave out any sensitive information such as URLs, passwords, etc.
Saving Comment Saving Comment...
Rating
Rating
  • "No brainer. I have purchased it for two production installations and not regretted it."

    Read More Reviews

Keep up to date on the latest additions

We'll send you an email every month with handpicked add-ons, reviews, tricks and tips. Don't worry, we hate spam as much as you do.