by eggsurplus

Control what your users can access and save time, money, and frustrations. Lock down sensitive data in SugarCRM or SuiteCRM to specific groups or teams. Supports unlimited assigned users, unlimited group assignments to records, custom layouts for each group, login/sudo capabilities and much more.

Free Trial

By clicking you consent to be contacted by the developer

#4376 - Advanced search-Assigned to field issue!

Closed Bug? created by it12 Verified Purchase a year ago

Hi Guys,

After upgrading from Security Suite 3.1.118 to latest version 3.1.19 I have found some potential problem with Advanced filter and Assigned to field in every module. If I search using Assigned To field which is built in drop down from the system I wouldn’t get any records if I choose multiple users…If I choose just one of them, I can see that records exists. Now this was working on 3.1.18 and Assigned To field behaved like it is OR condition when querying, now it seems like with 3.1.19 is AND condition. This happens in every module inside of SuiteCRM.

I would like to restore this feature to prior behavior. Thank you in advance.

Best Regards,

Slaven.

  1. eggsurplus member avatar

    eggsurplus Provider Affiliate

    a year ago

    Hi Slaven,

    Someone else has reported this behavior recently as well. Did you also upgrade your CRM? If so, to which version? I'm looking to see if it is more related to the new CRM version so that we can handle whatever changes were made.

    Thanks! Jason

  2. it12 member avatar

    it12 Verified Purchase

    a year ago

    Hi Jason,

    Thanks for getting back. Good to know that you guys are working on it. Can you please send me 3.1.18 version and guide on how can I revert cleanly to that version while this issue persists.

    We are on 7.8.8 because of old themes that are missing. Not sure if I can freely update to 7.8.31 without breaking any custom code or similar.

    Best Regards,

    Slaven.

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      a year ago

      A new package will be ready by Monday. The issue has been fixed and will go out in this next package.

  3. eggsurplus member avatar

    eggsurplus Provider Affiliate

    a year ago

    This has been fixed in the 3.1.20 release that is now available under your purchases at https://www.sugaroutfitters.com/orders.

    Install using Module Loader WITHOUT installing first. Leave the existing version. Then be sure to run the following after installation:

    • Quick Repair & Rebuild
    • Rebuild Relationships
    • Repair Roles

    Let me know if you have any questions or run into anything.

    Thanks! -Jason

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      a year ago

      "Without uninstalling" is what I meant. Do not uninstall the existing SecuritySuite version. Just install the new version on top of it.

This case is public. Please leave out any sensitive information such as URLs, passwords, etc.
Saving Comment Saving Comment...
Rating
Rating
  • "We have big problem with SuiteCRM v.7.3.1 when creating custom screen by group. The Dashlets on the start page disappear for all user, we have this pr..." - claude_f.

    Read More Reviews