by eggsurplus

Control what your users can access and save time, money, and frustrations. Lock down sensitive data in SugarCRM or SuiteCRM to specific groups or teams. Supports unlimited assigned users, unlimited group assignments to records, custom layouts for each group, login/sudo capabilities and much more.

Cancel at any time!
Free Trial

#3820 - Enable/Disale in "Access" column is inconsistent in free 6.5.13_SecuritySuite_LIMITED_v2.6.5 version

Closed Bug? created by rodnikosh Verified Purchase a year ago

Hello,

i'm using an Sugarcrm Comunity vesion 6.5.13 and we are very happy with it
we installed version 6.5.13_SecuritySuite_LIMITED_v2.6.5 that is free to use and
it works great (also made the code changes needed in "cusom/metadata" files).

The problem is that when i add the teams role to a user that already has a role and i want to combine the two,
i can see that the the two roles override the "Access" column inconsistently:
for some modules, the "Enabled" overrides the "Disabled" and for other modules the "Disabled" overrides the "Enabled".

How do i solve that?
also willing to pay for a fix if needed...

  1. eggsurplus member avatar

    eggsurplus Provider Affiliate

    a year ago

    Hello,

    That generally doesn't happen. One way that it could is if you have roles assigned both to the groups and to the user directly. Depending on your SecuritySuite settings it could appear inconsistent in that case if you have something like Enable Strict Rights on.

    However, it should always be either the greatest of rights or the most restrictive of rights among all of a user's roles.

    Could you check your settings and see if anything there could be in play?

  2. rodnikosh member avatar

    rodnikosh Verified Purchase

    a year ago

    Checked it. the roles are different. there is the "Team role" that i related to the Team i created and there is a "salesman" role that only related to the user (not to the team too). so both the "Teams role" and "salesman" role are related to the user.
    These are my settings, should i try something different?

    Securitysuite.JPG

  3. rodnikosh member avatar

    rodnikosh Verified Purchase

    a year ago

    yes. it was fixed when i unchecked "User Role Presence". Thank you!!

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      a year ago

      Perfect! Glad that you have it working as desired now.

This case is public. Please leave out any sensitive information such as URLs, passwords, etc.
Saving Comment Saving Comment...
Rating
Rating
  • "SecuritySuite was a very good addition to our SugarCRM implementation helping to integrate different functional teams with strictly specified roles."

    Read More Reviews

Keep up to date on the latest additions

We'll send you an email every month with handpicked add-ons, reviews, tricks and tips. Don't worry, we hate spam as much as you do.