by eggsurplus

Control what your users can access and save time, money, and frustrations. Lock down sensitive data in SugarCRM or SuiteCRM to specific groups or teams. Supports unlimited assigned users, unlimited group assignments to records, custom layouts for each group, login/sudo capabilities and much more.

Free 30 day trial
Try it Now

#2910 - Help Our Licence Validation Is Not Working.

Closed Installation created by AT Verified Purchase 2 years ago

Hi There,
We have updated our licence, but the validation process is not working. We are getting messages that the SecuritySuite is no longer active. When I attempted to validate the license it failed. I have checked our settings and we have an HTTPS port that is open, also our certificates are up to date. Can you help please.

  1. eggsurplus member avatar

    eggsurplus Provider Affiliate

    2 years ago

    It looks like the validation is working, but the error message is still displaying. This can happen if you have a cache enabled such as APC or Memcache. If you restart Apache the message should then go away. If it doesn't then it means that the key couldn't save correctly in config_override.php in your root CRM folder due to file permission issues.

    Hope this helps!

    • AmanaTrust member avatar

      AT Verified Purchase

      2 years ago

      We still have the proble,. I have restarted Apache and checked file permissions on config_override.php. What else could be causing this problem? Thanks.

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      2 years ago

      Are the group permissions still working as they should? Meaning that folks with group rights can see records from other users in the same group? If so, then it's working, but an error display issue. Another thing to try is a Quick Repair & Rebuild and then restarting Apache again.

      Do you see the following row in your config_override.php?

      $sugar_config['outfitters_licenses']['securitysuite']
      

      If not, revalidate the key so that it can write it to that file.

  2. AmanaTrust member avatar

    AT Verified Purchase

    2 years ago

    I have done a rebuild and repair, then restarted Apache. The config row row exists in the config_override.php file with the key as the value for that setting.

    BTW I did a test of the validation of the license on my dev machine. It worked OK. My dev machine is windows 10 running apahce2, and prod is a linux server. Not sure if this helps.

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      2 years ago

      Were you able to confirm that security group permissions are working correctly for users? At this point it sounds like it is and that the issue is a display issue. This will be caused by some sort of opcode cache, server side cache. I'm not sure how your server is configured, but if that cache can be invalidated/reset then the error will go away.

  3. AmanaTrust member avatar

    AT Verified Purchase

    2 years ago

    The Security group permissions are not work properly. They can only see contacts that are assigned to them, but not in the security group.

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      2 years ago

      There is one other possibility and it is related to the Amazon issues this past week. It has affected at least one other customer of ours. Here is what they had to do:

      It was an issue with the Amazon DNS we are using for our servers. From what I could see, your domain could not be resolved. I have fixed it by hardcoding the IP on your domain.

      I believe what they are referring to is editing /modules/SecurityGroups/license/config.php and replacing www.sugaroutfitters.com in the api_url to 104.130.124.191

  4. AmanaTrust member avatar

    AT Verified Purchase

    2 years ago

    I have done that. I am getting a new message now: Failed: Public Key does not exist.

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      2 years ago

      Something just isn't adding up. I'm going to send you an email right now. Please change the config back to what it was for now.

  5. eggsurplus member avatar

    eggsurplus Provider Affiliate

    2 years ago

    While we weren't able to find the specific cause, the message disappeared once we edited a file on the server. My best guess is that caused the display message to flush out of the cache.

  6. AmanaTrust member avatar

    AT Verified Purchase

    2 years ago

    Thank you for your timely support and resolution for this issue.

This case is public. Please leave out any sensitive information such as URLs, passwords, etc.
Saving Comment Saving Comment...
Rating
Rating
  • "SecuritySuite was a very good addition to our SugarCRM implementation helping to integrate different functional teams with strictly specified roles."

    Read More Reviews

Keep up to date on the latest additions

We'll send you an email every month with handpicked add-ons, reviews, tricks and tips. Don't worry, we hate spam as much as you do.