by eggsurplus

Control what your users can access and save time, money, and frustrations. Lock down sensitive data in SugarCRM or SuiteCRM to specific groups or teams. Supports unlimited assigned users, unlimited group assignments to records, custom layouts for each group, login/sudo capabilities and much more.

Cancel at any time!
Free Trial

#2735 - Cannot link Users to Security Group - SuiteCRM 7.6.10

Closed Bug? created by dfstrauss 3 years ago

We are in the process of upgrading from SugarCRM CE to SuiteCRM 7.6.

The upgrade seems to have worked fine; except that on the "Security Groups Management" view we cannot add users to a Security Group. Clicking "Select" pops up the user search window. If you then click on a User the popup closes but the user is not added.

Adding Roles on the same screen works fine.

  1. eggsurplus member avatar

    eggsurplus Provider Affiliate

    3 years ago

    Have you reinstalled SecuritySuite with the 7.6.10 version for SuiteCRM after upgrading? Also try running a Quick Repair & Rebuild and then a Repair Roles after installing the 7.6.10 version.

    • dfstrauss member avatar

      dfstrauss

      3 years ago

      Thanks for the quick response.

      I have just discovered my mistake. I mis-merged the Users/vardefs.php file and did not have the "securitygroups_users" relationship. Fixing the merge error cleared up the issue.

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      3 years ago

      Whew! Glad that you were able to get that figured out.

  2. dvkesarwani member avatar

    dvkesarwani

    2 years ago

    i m getting same issue, but mine "securitygroups_users" relationship is perfect.
    Suitecrm version 7.8.6 and securitygroup version in 6.5.24

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      2 years ago

      I suggest checking the suitecrm.log in the root SuiteCRM directory to see if there are any errors when you run into this problem. That may lead you to some clues.

      Also try running a Quick Repair & Rebuild, Repair Roles, Repair Relationships, and Quick Repair & Rebuild (again).

      The problem was solved above by fixing the modules/Users/vardefs.php file. It may be worth spinning up a blank, new 7.8.6 instance, installing SecuritySuite for 7.8.6 in it, and comparing that file to your production version to see what the differences are.

  3. dvkesarwani member avatar

    dvkesarwani

    2 years ago

    still not working

  4. dvkesarwani member avatar

    dvkesarwani

    2 years ago

    i am able to add users from security group detail page, but not able to add from users detail page via securitygroup subpanel.

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      2 years ago

      Did you try the suggested fixes above including the vardefs.php fix and all of the different repairs?

  5. dvkesarwani member avatar

    dvkesarwani

    2 years ago

    yes, still getting error.

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      2 years ago

      Are you using the free version that comes with SecuritySuite? If so, that is likely why. There looks to be a bug in that version. I'm able to test and confirm that the paid version available here does work on the user detail page.

This case is public. Please leave out any sensitive information such as URLs, passwords, etc.
Saving Comment Saving Comment...
Rating
Rating
  • "The features are exactly what is needed to turn a SugarCRM CE into a Teams based CRM."

    Read More Reviews

Keep up to date on the latest additions

We'll send you an email every month with handpicked add-ons, reviews, tricks and tips. Don't worry, we hate spam as much as you do.