by eggsurplus

Control what your users can access and save time, money, and frustrations. Lock down sensitive data in SugarCRM or SuiteCRM to specific groups or teams. Supports unlimited assigned users, unlimited group assignments to records, custom layouts for each group, login/sudo capabilities and much more.

Free 30 day trial
Try it Now

#2412 - Upgrading to full version

Closed Bug? created by dmitrychichkalenko 3 years ago

Hi

I tried to upgrade SecuritySuite to full version on SuiteCRM 7.6.6. After purchase I downloaded correct zip file for my version of Suite and installed it. Installation went fine but at the end of the installation I wasn't redirected to license validation page and after refreshing browser got an error HTTP 500 and now I can't reach UI

  1. dmitrychichkalenko member avatar

    dmitrychichkalenko

    3 years ago

    upd

    On testing instance of Suite 7.7.0 installation went fine and I was redirected to license validation page, however when I tried to validate key I got a message "SugarOutfitters_API::call(): Unable to validate the license key. Please configure the firewall to allow requests to https://www.sugaroutfitters.com/api/v1/key/validate and make sure that SSL certs are up to date on the server."

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      3 years ago

      Make sure that php_curl is enabled and that your server can connect to https://www.sugaroutfitters.com. This error will happen if either of those are not done.

      For your 7.6.6 install, that could have been a file permissions issue where SuiteCRM couldn't unzip and copy the files to where it needed to. Fixing that and then reinstalling will usually do the trick.

    • dmitrychichkalenko member avatar

      dmitrychichkalenko

      3 years ago

      Could you provide some info on where to check file permissions?

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      3 years ago

      This is the script I always recommend for fixing permissions: http://www.shanedowling.com/sugarcrm-permissions-script/

      However, depending on your specific setup, you may need to also set the default_permissions in your config.php so that new files get created with the correct rights. I don't have more information on that, but I know Google has some hits for that specific need. It is needed some times, but is rare enough that I haven't personally ran into it.

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      3 years ago

      Just following up. It was confirmed over email that the license can now validate after enabling php_curl.

  2. dmitrychichkalenko member avatar

    dmitrychichkalenko

    3 years ago

    Unfortunately script didn't help
    When I install clean version of SuiteCRM on the same server everythnig is fine. It seems that the problem with customisations, any tips what to try now?

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      3 years ago

      Sorry, it will greatly depend on your OS and how you have it configured. With a 500 error, do check the Apache logs and PHP logs. There may be some hints in there.

  3. dmitrychichkalenko member avatar

    dmitrychichkalenko

    3 years ago

    I even don't know where to look for, please give me a hint

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      3 years ago

      This can be the challenge of self hosting. Sorry! It's frustrating and I've been there many times. I would suggest starting by Googling for "ubuntu where are the apache logs" and switch out Ubuntu for whichever OS you are using. Then follow along with the suggested locations to see if you can find the latest, active log. Also try to find the PHP logs as they may contain different information. A 500 error is telling me that the install failed due to being unable to copy the files over during that stage of install. That always happens due to file permission issues.

      Also check your suitecrm.log which is found in the root SuiteCRM directory. There may be something there relevant to this issue such as a database error.

  4. dmitrychichkalenko member avatar

    dmitrychichkalenko

    3 years ago

    When server corrupted last time I checked suitecrm.log and there were nothing about installation, last record was hours before installation.
    Right after installation I made a PrintScreen of SuiteCRM page, maybe it will give you some additional info (sorry for language). Refreshing page from this stage gives 500 error

    https://drive.google.com/file/d/0ByhPBtxshrRfYTNqQzhTQlJFS2c/view?pref=2&pli=1

    As you suggested, I will check php and apache logs.

    Thank you

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      3 years ago

      That screenshot is as expected. Hopefully you are able to find something in either the Apache or PHP logs. Are you able to instead just spin up a new instance? Since you have 7.7.0 up and running correctly I would hope that a new install would work just as well as that.

  5. dmitrychichkalenko member avatar

    dmitrychichkalenko

    3 years ago

    Upgrading our current instance from 7.6.6 to 7.7.0 didn't help.
    But when we cloned server and made fresh suitecrm install everything worked fine.
    We can go with fresh install, but we will need to transfer all customisations along with huge database.

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      3 years ago

      You may find in the logs that files are missing in your problem instance because the system failed to copy files over. Another option is to unzip the SecuritySuite zip file, go to /install_dir/notupgradesafe, and copy the contents of that directly into your SuiteCRM app directory. This should fill in all of the missing files. Double check file permissions after doing that for all of the copied files.

  6. dmitrychichkalenko member avatar

    dmitrychichkalenko

    3 years ago

    Nothing helped (( Decided to move on to new instance. However, on new instance found another bug - in role management I don't see create column. Need help.

  7. dmitrychichkalenko member avatar

    dmitrychichkalenko

    3 years ago

    my fault, I found in previous cases that I need to repair roles - now works

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      3 years ago

      Are you all set on the new instance? Did the issues go away after moving?

    • dmitrychichkalenko member avatar

      dmitrychichkalenko

      3 years ago

      At least for now, thanks. You can close the case

This case is public. Please leave out any sensitive information such as URLs, passwords, etc.
Saving Comment Saving Comment...
Rating
Rating
  • "Couldn't do without it. Highly recommended and I guarantee that you will not find another alternative."

    Read More Reviews

Keep up to date on the latest additions

We'll send you an email every month with handpicked add-ons, reviews, tricks and tips. Don't worry, we hate spam as much as you do.