by eggsurplus

Control what your users can access and save time, money, and frustrations. Lock down sensitive data in SugarCRM or SuiteCRM to specific groups or teams. Supports unlimited assigned users, unlimited group assignments to records, custom layouts for each group, login/sudo capabilities and much more.

Free 30 day trial
Try it Now

By clicking you consent to be contacted by the developer

#104 - Security Groups preventing subpanel record viewing/editing

Closed Bug? created by dgreene 9 years ago

For the life of me i can not find out why we can no longer view any subpanels under an account. These are not viewable under any role. I've tried everything. Uninstalling the security suite trashes my database. I need help ASAP to get this fixed. We can't create/view/edit notes, calls, meetings, history, contacts (from the account record) etc.

  1. eggsurplus member avatar

    eggsurplus Provider Affiliate

    9 years ago

    What version of SugarCRM are you running? What other modules do you have installed? I haven't heard of this issue before. As far as uninstalling goes, there was a bug in SugarCRM that caused uninstalls to not roll back files correctly up until 6.5.5. I do see you had EasyTheme running at one point. That would make sense for the subpanel issue as it touches that area heavily.

    • dgreene member avatar

      dgreene

      9 years ago

      I'm running the latest version of sugarce with mssql. I have easy theme and advanced open sales. It is not occurring in my sandbox test environment, just production

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      9 years ago

      When I hear that it makes me think it is a file permissions issue then in production. All other things between the two systems are the same, otherwise?

    • dgreene member avatar

      dgreene

      9 years ago

      File permission issue? Not sure I follow. I'm not getting any errors. But yes, both systems are the same and on the same server

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      9 years ago

      You may not get errors. Depends on your configuration. Have you tried a Repair/Rebuild yet? My best guess based on what you describe is that the files that generate the subpanels cannot be read/executed by Apache (or whatever the webserver is) due to insufficient file permissions. Here are some links I usually share that may or may not help: http://support.sugarcrm.com/04_Find_Answers/02KB/02Administration/100Troubleshooting/Troubleshooting_Issues_With_Filesystem_Permissions http://forums.sugarcrm.com/f3/sugarcrm-permissions-50083/

  2. dgreene member avatar

    dgreene

    9 years ago

    Yes I've done all the rebuilds (quick, relationship, role) multiple times. Could it be a group issue? I can see some things (like contracts) that haven't been relationship linked to the security suite through the tool. That's why I'm convinced its an issue with the module. I went as far as deleting all the groups and still can't see those sub panels.

    • eggsurplus member avatar

      eggsurplus Provider Affiliate

      9 years ago

      The only possible relationship with groups and subpanels is if a user's permission for a module is disabled in one of their roles. SecuritySuite was developed on MSSQL so I don't think that's a problem either. Is SecuritySuite installed on the sandbox where everything is working fine? If so, I still see it as a file permissions issue. Sorry, I just haven't seen any critical bugs like this in years with the module so highly doubt that SecuritySuite is causing it. Although I've seen weirder things before.

  3. dgreene member avatar

    dgreene

    9 years ago

    No issues in my test environment, that's why I rolled it into production. :-/

  4. eggsurplus member avatar

    eggsurplus Provider Affiliate

    9 years ago

    Another possibility; if 0 subpanels show under an account I wonder if processing stopped due to a PHP error or a JS error. Do you have PHP error logging enabled? Are you able to see if anything has been logged? Anything in the browser console for JS errors? Can you try going to the Account via a different path such as through the list view. Then try edit/save. Any of those bring up the subpanels?

  5. dgreene member avatar

    dgreene

    9 years ago

    Again, no errors. The sun panels are listed (headers) but the only detail panels show under contracts and docusign (the two modules not linked to security suite. On the edit screen the panels aren't available anyway. The list screen shows what I mentioned above. All The sub panels are available through the contact screen, just not the account screen-only headers (like permissions don't allow viewing)

  6. eggsurplus member avatar

    eggsurplus Provider Affiliate

    9 years ago

    Working offline on this it looks like a Firefox specific issue and we aren't able to pinpoint the cause yet. There's an off chance that it may be due to another module not working well with SecuritySuite. Closing this issue for now unless something else comes up.

This case is public. Please leave out any sensitive information such as URLs, passwords, etc.
Saving Comment Saving Comment...
Rating
Rating
  • "Very responsive development team, both in their communication and in having improvements incorporated and issues resolved." - kevin

    Read More Reviews