by eVolpe Consulting Group

Are you facing difficulties trying to coordinate efforts between marketing and sales? The Sugar/SuiteCRM & Mautic Integrator by eVolpe is the best solution that will help you solve this issue. TRY IT NOW FOR FREE!

Cancel at any time!
Free Trial

#3540 - Stalled on Authorize stage

Closed Installation created by mpeet1 a year ago

HI, trying to configure the integrator between my SuiteCRM installation and Mautic. It is stalled at the authorization stage - when I click the LINK to generate access tokens in Admin -> Connectors -> Set Connector Properties -> Mautic tab I get the following error

ERROR: The requested URL /oauth/v2/authorize was not found on this server.

The URL generated is in the form

https:///mautic/get_token?state=0981a3c794e82bf194ec452928ec6525&code=ZWZkOGNkYzZhNjliYTY3ZThhOTAyYzA0N2QwYjIwNDQwOTdjOGNmMTkzOTdhMDJkOThhOWZiOTU1MmNlZWQwNw

SuiteCRM 7.9.9
Mautic 2.12.1
PHP 7.0.27

Thanks for your time and patience

  1. mpeet1 member avatar

    mpeet1

    a year ago

    Hi, I have tried this with a multitude of different settings, once I have been redirected to your 'SugarCRM would like to authorize screen' (this was an EXTERNAL page?) and now I am getting the following error **EVERY **time I click on the Link field

    The requested URL /mautic/get_token was not found on this server.

    The URL generated via the link in my SuiteCRM Connector settings is

    https://mycrm.edu.au/mautic/get_token?state=c6eee14b1177ab2fffc96e0770f49ef1&code=MDU3MjE2Y2I4OGE2OTM0OWFjYjUzMTI0Njk5ZjQzYTA2ZmFkNTgzYTU5NGI3MWRiMDRjOTQ2NWIzOTYwNGZkMg

    Each time I have attempted to generate the token I have deleted the app/cache/prod folder. I have checked the API Credentials and API Settings in Mautic. I have checked the Consumer Key and Secret are correct

    Does this module work with SuiteCRM as it's based on the Sugar 6 version?

    Thanks for your time and patience and any assistance you can give me

    • Reeta member avatar

      Reeta

      a year ago

      Hi, are you find your solution for this "The requested URL /mautic/get_token was not found on this server.". because i also got the same error every time and i also set all the setting that you have done.

  2. mpeet1 member avatar

    mpeet1

    a year ago

    Sorry, just found a post on your site that says the plugin/module DOESN'T work on both my SuiteCRM and Mautic versions, apologies for the wasted posts. Any ideas/timeline on when it will work on Mautic 2.12.1?

    Thanks for your time and patience

  3. eVolpe_Consulting_Group member avatar

    eVolpe Consulting Group Provider

    a year ago

    Hi mpeet1,
    What version of SuiteCRM do you have? We are planning to release new version that supports mautic 2.12 next week. However the problem that you experience does not seem to be related to the mautic version mismatch in regards to integarator version since our current tests and upgrades in the package do not involve any changes related to that part of the whole mechanism. It might be however related to some configuration problem regarding domains of both systems.

    We will be contacting you via e-mail to establish more details to help you with your problem.

  4. mpeet1 member avatar

    mpeet1

    a year ago

    Hey guys, I have downloaded/installed your NEW integration for Mautic v 2.12.1 and have run into the same problem. The FIRST time I clicked on the CLICK THIS LINK link I was redirected and offered the page to allow access. When I clicked on Allow I was again redirected and received the following error message

    The requested URL /mautic/get_token was not found on this server.

    I have gone over your complete installation and configuration guides and tried the steps 3 times now with the same results...

    SuiteCRM v7.9.9
    PHP 7.0.27
    Apache 2.0

    Both installations (Mautic and SuiteCRM) are running on Amazon LightSail using the Bitnami stack, the Apache user:group is daemon:daemon. I currently have the Mautic Sugarcrm plugin installed and working as it should - does this need to be disabled for your module to work or is it OK to run concurrently? Does the module link using contact records as well as leads or just leads?

    Any assistance you can give me to get the synch working, greatly appreciated...

  5. mpeet1 member avatar

    mpeet1

    a year ago

    I have noticed in Mautic -> Configuration -> Plugins -> eVolpe Marketing Automation Integration -> Contact Mapping that there are TWO Email Address fields on the SuiteCRM side of the mapping - I'm hoping one is for Leads the other for Contacts or is this a Bug?

  6. mpeet1 member avatar

    mpeet1

    a year ago

    Got the module to start working after some conversations wth the developers (thanks Aleksandra, great support!!!) and adjusting the following settings:

    • Add the AllowOverride All to the Directory listing in the httpd.conf file for the VHOST
    • Add the following to the config_override.php file for the site

      • $sugar_config['http_referer']['list'][0] = 'mauticsiteurl';

      • $sugar_config['http_referer']['actions'] =array( 'index', 'ListView', 'DetailView', 'EditView', 'oauth', 'authorize', 'Authenticate', 'Login', 'SupportPortal', 'ConnectorSettings' );

    Great support to get this module working

This case is public. Please leave out any sensitive information such as URLs, passwords, etc.
Saving Comment Saving Comment...
  • "This works brilliantly! It is exactly what we were looking for."

    Read More Reviews

Keep up to date on the latest additions

We'll send you an email every month with handpicked add-ons, reviews, tricks and tips. Don't worry, we hate spam as much as you do.