by GrinMark

Make life easier by reducing the need to flip between apps. If you are using Outlook Web App, Outlook 2013, or Outlook 2016 connected to Office365 or Exchange Server 2013 then be sure to take advantage of this email and contact synchronization add-on. Smartly links emails to your Sugar records and keeps your contacts in sync.

Free 30 day trial
Try it Now

By clicking you consent to share your profile with the developer

#3072 - Login to suiteCRM fails (invalid login)

Closed Bug? created by fwtag 5 years ago

Hi there,

the login setup of the Outlook365 > SugarCRM Addin fails with "Login attempt failed please check the username and password (Invalid Login)" when hitting Test Connection. The user is synced via LDAP.

When using a local admin user, the Text Connection process leads to "Fail: admin. You do not have access (Access Denied)" which is quite strange since the admin user has any right which is available.

I checked and updated the php.ini as recommended in an other thread without any effect.

Questions: - How can I debug what acutally happens? - Does this behavior might be related to the fact that I am using the SugarCRM addin together with suiteCRM (which might be my fault and I will change this after sending this case)? - Does this behavior might be related to the fact that the server hat PHP 5.3? Do we need to update?

Any assistance is appreciated. Frank

  1. fwtag member avatar

    fwtag

    5 years ago

    Edit: The suiteCRM addin shows the same bahavior.

  2. GrinMark member avatar

    GrinMark Provider Affiliate

    5 years ago

    Hi Frank,

    We have a LDAP switch in config because LDAP authentication works a bit differently than normal one. But it is not available from the UI. I've set the flag. Could you load the plugin again, retype the password and retest connection? Should work this time.

    Regards, Denis

    • fwtag member avatar

      fwtag

      5 years ago

      Thanks. It works.

    • fwtag member avatar

      fwtag

      5 years ago

      Please refer to my later comment. Any news? Any ideas?

  3. fwtag member avatar

    fwtag

    5 years ago

    The both "Test Connection" settings lead to success, also the creation of a new contact works well, apart from that a newly created Account in CRM does not show up.

    But when I try to archive an email, I get the following error: "Failed to archive email. Please test Exchange and CRM connection on the Settings tab."

    BTW: I can't select where to attach the mail that shall be archived. Is that correct?

    Frank

  4. GrinMark member avatar

    GrinMark Provider Affiliate

    5 years ago

    Hi Frank,

    Synchronization of Accounts is not supported in the plugin. If you need more sophisticated sync scenarios consider AESync.

    Could you retest email archiving one more time? I'll trace it in the logs.

    Regards, Denis

    • fwtag member avatar

      fwtag

      5 years ago

      I started an archiving process by hitting "Archive this Email" (with any Email) just right now. Same effect.

  5. fwtag member avatar

    fwtag

    5 years ago

    Hi there, any news?

    Frank

  6. GrinMark member avatar

    GrinMark Provider Affiliate

    5 years ago

    Hi Frank,

    I see no errors on our side. Could you check sugarcrm.log after archiving attempt? Possibly there is some problem in Sugar permissions configuration.

    Regards, Denis

  7. fwtag member avatar

    fwtag

    5 years ago

    Hi Denis,

    ok, maybe we should start from a different point of view.

    My starting point is an email from Mrs X to myself. I want to transfer this email to SuiteCRM. A contact in SuiteCRM with identical name and email address of Mrs X exists.

    I hit "SuiteCRM > Archiving" and than "Archive this Email".

    Expected behavior: - The Add-In should show a contact proposal (the existing Mrs X contact) to me /or/ - I should be able to select a contact to attach the email to.

    Actual behavior: - The Add-In shows the button "Archive this Email" only - When hitting it, a progress bar "Synchronizing, pease wait" starts. - After a while, the following error message occurs:

    Bildschirmfoto 2017-05-08 um 08.38.18.png

    Details: - sugarlog.crm shows many database query (ok, the log level ist "debug"), containing queries for Mrs X' contact details and mine.

    What am I doing wrong? Do I expect something wrong?

    Please remember that login/access is done via LDAP auth.

    Frank

    • fwtag member avatar

      fwtag

      5 years ago

      Note: The "Test Connection" features of both, Exchange and CRM succeed. And - I was able to generate a contact.

  8. GrinMark member avatar

    GrinMark Provider Affiliate

    5 years ago

    Hi Frank,

    Expected behavior is: 1. You press Archive Email button 2. The plugin shows "Synchronizing..." for a while 3. Then the result is displayed - with all automatically linked contacts. Contact matching is done by email address. You can link additional contacts only after email was archived.

    But you never get to #3 because of some error. Let me check something and I'll get back to you later today.

    Regards, Denis

  9. GrinMark member avatar

    GrinMark Provider Affiliate

    5 years ago

    Hi Frank,

    When the plugin tries to save an email into CRM it receives Access Denied response.

    Please check that - Emails module tab is enabled - User has Write permission for Emails module

    Regards, Denis

  10. fwtag member avatar

    fwtag

    5 years ago

    OK, the Email permissions have been missing since we do not use this feature. (I did enable permission, but not the mail tab - do I need to do so?) Archiving the mail does actually work now - BUT after successful archive process, the overlay re-appears and shows the same error message. Is this related to the missing mail tab?

  11. fwtag member avatar

    fwtag

    5 years ago

    Cross-checked with E-Mail module enabled. Same effect.

  12. GrinMark member avatar

    GrinMark Provider Affiliate

    5 years ago

    Hi Frank,

    Could you try to archive using Mass Email Archiving feature? Just mark the email with ToCRM category and trigger archiving on Synchronization tab.

    Regards, Denis

  13. fwtag member avatar

    fwtag

    5 years ago

    Hi Denis,

    something seems to be broken (again?). When I try to perform an mass archive or a distinct archive of the mail, I get a "Fail: You don't have Access (Access Denied)", although nothing has been changed. The "Text Connection" button to the CRM shows the same result.

    I really don't know what ist going on here, but after all the product seems not to be quite stable ... maybe because we are using LDAP authentication.

  14. fwtag member avatar

    fwtag

    5 years ago

    BTW: When trying user "admin" (which is a local user with over-all permissions), it fails as well.

  15. GrinMark member avatar

    GrinMark Provider Affiliate

    5 years ago

    Hi Frank,

    Just checked again, it works from my side. To me it looks like instability in CRM or connection to it. I suggest to arrange a gotomeeting session since it is unusual situation. Please propose a few times by email to support@grinmark.com.

    Regards, Denis

This case is public. Please leave out any sensitive information such as URLs, passwords, etc.
Saving Comment Saving Comment...
Rating