by Rolustech

Become more efficient! Enter everything just once. Automatically sync Emails, Calendars, Contacts, and Documents between Google Apps and Sugar. Get your Gmail, Contacts, Calendar items and Documents automatically synced instantly with this seamless integration.

Free Trial

By clicking you consent to share your profile with the developer

#2991 - Can't connect to Google

Closed Bug? created by cambridgepicture 5 years ago

I have installed the module, authorised a user and entered their Google username and password but can't get them authenticated with Google. When I go to the edit user page, enter the credentials and click "Test", I get a pop-up saying "successful". However if I deliberately enter the wrong password I still get the "successful" popup, and no Google authentication pop-up appears in either case and nothing syncs thereafter.

I'm using SuiteCRM Version 7.8.2 (Sugar Version 6.5.24 (Build 509)), and connecting to a Google Apps account.

There's nothing showing in the log, but in the apache2 error.log I find:

[Thu Mar 30 15:23:17.022617 2017] [:error] [pid 8760] [client ***IPAddressRemoved***:37418] PHP Notice:  Undefined offset: 1 in /var/www/suitecrm/Zend/Gdata/ClientLogin.php on line 150, referer: https://***domainremoved***/index.php?module=Users&offset=1&stamp=1490887361048921000&return_module=Users&action=EditView&record=b53b883f-1cfa-3137-bda5-58dce7202742
  1. rolustech-primary-contact member avatar

    Rolustech Verified Purchase

    5 years ago

    Hi,

    Thanks for reaching out to Rolustech. Can you please send your CRM's URL, admin credentials and the email address credentials you are trying to enable RT Gsync for on our support account: support@rolustech.com

    Our support team would recreate the issue and fix it for you as soon as possible.

    Regards,

    Support Team

  2. cambridgepicture member avatar

    cambridgepicture

    5 years ago

    I have fixed it. It seems that I needed to enter the Google credentials, then click 'save' and that would bring up the authentication screen and make the connection. It is now syncing. However if I click "Test Connection" I get nothing. It seems like the "Test Connection" button is not working properly.

This case is public. Please leave out any sensitive information such as URLs, passwords, etc.
Saving Comment Saving Comment...
Rating
  • "Been trying to get this to work for two weeks. Very little support. I hope it works but to this day, it does not." - meyerwells

    Read More Reviews